Cookies Netscape и Mozilla под угрозой

Обнаружены дыры в программном коде браузеров Mozilla и Netscape, которые дают возможность злоумышленнику получить доступ к файлам cookies на компьютере пользователя.

Проблема касается браузеров Netscape, начиная с версии 6.0 и выше — до 6.2.1, и браузеров Mozilla до версии 0.9.7. Для получения доступа к чужим cookies потенциальному злоумышленнику достаточно разместить на веб-странице или в электронном html-сообщении гиперссылку определенного вида, в результате чего «дырявые» браузеры отсылают cookies, предназначенные для совсем другого сайта, по указанному адресу.

Netscape и Mozilla уже выпустили обновленные версии браузеров (Netscape 6.2.1 и Mozilla 0.9.7), в которых уязвимость устранена.
Пока не зафиксировано случаев злонамеренного использования дыр. Однако все-таки не будет лишним обновить свое ПО, так как нарушение безопасного соединения может привести к самым различным последствиям.
Уязвимость обнаружил еще 15 ноября 2001 года программист Марк Слемко, после чего он передал информацию о дырах компаниям-разработчткам браузеров Netscape и Mozilla. Информация о дыре была обнародована только после выпуска соответствующих апдейтов.

Публикации на схожие темы

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *