Серьезная брешь в защите Unix

Обнаружена уязвимость в защите Unix. Об этом сообщает официальный совместный бюллетень компании Internet Security Systems (ISS) и организации Computer Emergency Response Team (Cert).

Ошибка присутствует в ряде версий HP-UX, IBM AIX, Sun Solaris, Caldera OpenUnix и UnixWare и Compaq Tru64 Unix.
Источником уязвимости является функция, используемая средой Common Desktop Environment (CDE). Из-за ошибки в способе запроса подтверждения подлинности клиента хакеры могут манипулировать данными и вызывать переполнение буфера. Многие распространенные Unix- и Linux-системы поставляются с установленной и активизированной по умолчанию средой CDE, а следовательно являются уязвимыми.

Руководитель отдела изучения уязвимости защиты ISS Дэн Ингвалдсон (Dan Ingevaldson) признал ошибку CDE достаточно серьезной, несмотря на то, что пока ни один из известных хакерских инструментов ее не использует.

Уязвимость была обнаружена уже месяц назад компанией Internet Security Systems, которая информировала об ошибке шесть производителей. Компании Caldera, Compaq и IBM уже разработали патч, закрывающий уязвимость в Unix. Однако Hewlett-Packard и SGI еще не разработали патч, а Sun вообще отрицает наличие проблемы.

Cert рекомендует пользователям до установки патчей ограничить или заблокировать доступ к Subprocess Control Services из ненадежных сетей.

Публикации на схожие темы

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *