Архив

Опасная уязвимость в ОС Solaris

Координационный центр CERT(Computer Emergency Response Team), специализирующейся на мониторинге проблем компьютерной безопасности, опубликовал информацию об обнаружении опасной уязвимости в операционных системах семейства Solaris версий 2.5.1, 2.6, 7, 8 и 9.

Обнаруженная уязвимость связана с пресловутой ошибкой переполнения буфера. Ошибка возникает при определенных условиях в службе X Window Font Service (XFS) (она также имеет название fs.auto), которая базируется на протоколе TCP/IP и предназначена для передачи шрифтов оконного интерфейса X Window на клиентские компьютеры. Используя ошибку переполнения буфера, злоумышленник может удаленно выполнить на компьютере жертвы любой код или вызвать программный сбой, который приведет к тому, что сервер прекратит обслуживать клиентов.

Во всех случаях, кроме Solaris 9, дыра имеется в вариантах ОС как для процессоров SPARC, так и для чипов Intel. Девятая версия Solaris для процессоров x86 пока находится на стадии тестирования, поэтому официально факт наличия в ней дыры не подтверждается. Однако если бета-версия и содержит уязвимость, то до выхода окончательного варианта Solaris 9 x86 уязвимость, скорее всего, устранят. Операционные системы семейства UNIX (SGI IRIX, NetBSD, OpenBSD) не имеют данной уязвимости. В компании HP проводятся исследования на предмет наличия аналогичной дыры в ОС HP-UX.

Компания Sun Microsystems подтвердила наличие уязвимости и в настоящий момент работает над соответствующей заплаткой. Однако до тех пор, пока он будет выпущена, представители компании рекомендуется пользователям отключить демон fs.auto, равно как и прочие службы, не использующиеся повседневно. Кроме этого, рекомендуется заблокировать порт 7100/TCP, хотя это и не является исчерпывающим решением проблемы.

Опасная уязвимость в ОС Solaris

Ваш e-mail не будет опубликован.

 

Отчеты

Таргетированная атака на промышленные предприятия и государственные учреждения

Эксперты Kaspersky ICS CERT выявили волну атак на предприятия и государственные учреждения нескольких стран Восточной Европы и Афганистана. В ходе исследования выявлено вредоносное ПО, ранее использованное в атаках, которые другие исследователи отнесли к APT TA428.

ToddyCat: неизвестная APT-группа, нацеленная на организации Европы и Азии

ToddyCat является относительно новой APT-группой, ответственной за серии атак на высокостатусные организации Европы и Азии. Два ключевых отличительных признака этой группы — ранее неизвестные инструменты, которые мы назвали «бэкдор Samurai» и «троянец Ninja».

Lazarus распространяет протрояненный DeFi-кошелек

Недавно мы обнаружили протрояненное DeFi-приложение, которое имплантирует в систему полнофункциональный бэкдор. Проанализировав этот бэкдора, мы обнаружили многочисленные совпадения с другими инструментами группы Lazarus.

MoonBounce: скрытая угроза в UEFI

В конце 2021 года мы обнаружили прошивку UEFI, в которую был внедрен вредоносный код, названный нами MoonBounce. В данном отчете мы подробно опишем принцип действия импланта MoonBounce и его связь с APT41.

Подпишитесь на еженедельную рассылку

Самая актуальная аналитика – в вашем почтовом ящике